summaryrefslogtreecommitdiffstats
path: root/systems/au/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/au/config.nix')
-rw-r--r--systems/au/config.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/systems/au/config.nix b/systems/au/config.nix
new file mode 100644
index 0000000..bd61f78
--- /dev/null
+++ b/systems/au/config.nix
@@ -0,0 +1,22 @@
+{ config, ... }: {
+ imports = [
+ ./disks.nix
+ ../../configs/hw/x220.nix
+ ../../configs/ppp.nix
+ ../../configs/retiolum.nix
+ ../../configs/xsessions
+ ];
+
+ krebs.build.host = config.krebs.hosts.au;
+
+ networking.wireless.enable = true;
+ networking.useDHCP = false;
+ networking.interfaces.enp0s25.useDHCP = true;
+ networking.interfaces.wlp3s0.useDHCP = true;
+ networking.interfaces.wwp0s29u1u4i6.useDHCP = true;
+
+ system.stateVersion = "20.03";
+
+ tv.hw.screens.primary.width = 1920;
+ tv.hw.screens.primary.height = 1080;
+}