summaryrefslogtreecommitdiffstats
path: root/pkgs/haskell/blessings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/haskell/blessings.nix')
-rw-r--r--pkgs/haskell/blessings.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/haskell/blessings.nix b/pkgs/haskell/blessings.nix
new file mode 100644
index 0000000..65661aa
--- /dev/null
+++ b/pkgs/haskell/blessings.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, base, bytestring, fetchgit, hspec, QuickCheck, lib, mylib, text }:
+
+mkDerivation {
+ pname = "blessings";
+ version = "2.3.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/blessings;
+ rev = "refs/tags/v2.3.0";
+ hash = "sha256-fS79UOHBMfJHyz7E0Rx4lKZSZOD2G99h2zuDT+SOUJQ=";
+ };
+ libraryHaskellDepends = [ base bytestring text ];
+ testHaskellDepends = [ base hspec QuickCheck ];
+ doHaddock = false;
+ # WTFPL is the true license, which is unknown to cabal.
+ license = lib.licenses.wtfpl;
+}
[cgit] Unable to lock slot /tmp/cgit/78000000.lock: Permission denied (13)