summaryrefslogtreecommitdiffstats
path: root/tv/source.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-03-20 15:37:44 +0100
committerjeschli <jeschli@gmail.com>2018-03-20 15:37:44 +0100
commit1a24eda531554bc14db80101b82001eae390219a (patch)
treed08d1f32647a760ec641cc70897628b9bb56e264 /tv/source.nix
parent651060327e5e7fb5d0f8b634a65ccf006bd2fe15 (diff)
parentf40372edae02126778df858bc93d89b53fe0723f (diff)
Merge branch 'staging/jeschli' of prism.r:stockholm into staging/jeschli
Diffstat (limited to 'tv/source.nix')
-rw-r--r--tv/source.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tv/source.nix b/tv/source.nix
index b5e3f7c..e5e5e04 100644
--- a/tv/source.nix
+++ b/tv/source.nix
@@ -6,6 +6,11 @@ with import <stockholm/lib>;
}@host: let
builder = if dummy_secrets then "buildbot" else "tv";
_file = <stockholm> + "/tv/1systems/${name}/source.nix";
+ pkgs = import <nixpkgs> {
+ overlays = map import [
+ <stockholm/krebs/5pkgs>
+ ];
+ };
in
evalSource (toString _file) [
{
@@ -20,6 +25,7 @@ in
tv = "/home/tv/secrets/${name}";
};
stockholm.file = toString <stockholm>;
+ stockholm-version.pipe = "${pkgs.stockholm}/bin/get-version";
}
(mkIf (builder == "tv") {
secrets-common.file = "/home/tv/secrets/common";