summaryrefslogtreecommitdiffstats
path: root/tv/configs/AO753.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
commit7acd1262519d8f15c8eb89a0dce968eb26d6b7d4 (patch)
tree71f807a36e60e126b6fdb0be51e70cde4bf64b4e /tv/configs/AO753.nix
parent7673c84204bd5bae0426b79c62e95dfccf846756 (diff)
parent7920cfad18e69ea30bbe5e70da2cd93e0bbc05cd (diff)
Merge branch 'tv' into master
Diffstat (limited to 'tv/configs/AO753.nix')
-rw-r--r--tv/configs/AO753.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/tv/configs/AO753.nix b/tv/configs/AO753.nix
new file mode 100644
index 0000000..c103ce2
--- /dev/null
+++ b/tv/configs/AO753.nix
@@ -0,0 +1,39 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../configs/smartd.nix
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ahci"
+ ];
+
+ boot.kernelModules = [
+ "kvm-intel"
+ "wl"
+ ];
+
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.broadcom_sta
+ ];
+
+ networking.wireless.enable = true;
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ nixpkgs.config = {
+ allowUnfree = false;
+ allowUnfreePredicate = (x: pkgs.lib.hasPrefix "broadcom-sta-" x.name);
+ };
+}