summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack-nix-cacher.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-12-20 19:37:46 +0100
committertv <tv@krebsco.de>2015-12-20 19:37:46 +0100
commita14be9e3aed1d6123f6fb99c7ca017ac2842c80d (patch)
tree3080dd1517e5179fe2feaa9e0103b5680695e18a /shared/2configs/shack-nix-cacher.nix
parent1346e53598ec77ed43f214752b0ce4be0b189646 (diff)
parent0971df6a745fd358ac9e4904d44ad48fbf0e8b6d (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'shared/2configs/shack-nix-cacher.nix')
-rw-r--r--shared/2configs/shack-nix-cacher.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/shared/2configs/shack-nix-cacher.nix b/shared/2configs/shack-nix-cacher.nix
new file mode 100644
index 0000000..7519bb3
--- /dev/null
+++ b/shared/2configs/shack-nix-cacher.nix
@@ -0,0 +1,25 @@
+{ pkgs, lib, ... }:
+
+{
+ krebs.nginx = {
+ enable = lib.mkDefault true;
+ servers = {
+ apt-cacher-ng = {
+ server-names = [ "acng.shack" ];
+ locations = lib.singleton (lib.nameValuePair "/" ''
+ proxy_set_header Host $host;
+ proxy_set_header X-Real-IP $remote_addr;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_pass http://localhost:3142/;
+ '');
+ };
+ };
+ };
+
+ krebs.apt-cacher-ng = {
+ enable = true;
+ port = 3142;
+ bindAddress = "localhost";
+ cacheExpiration = 30;
+ };
+}