summaryrefslogtreecommitdiffstats
path: root/shared/2configs/graphite.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-12-20 19:37:46 +0100
committertv <tv@krebsco.de>2015-12-20 19:37:46 +0100
commita14be9e3aed1d6123f6fb99c7ca017ac2842c80d (patch)
tree3080dd1517e5179fe2feaa9e0103b5680695e18a /shared/2configs/graphite.nix
parent1346e53598ec77ed43f214752b0ce4be0b189646 (diff)
parent0971df6a745fd358ac9e4904d44ad48fbf0e8b6d (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'shared/2configs/graphite.nix')
-rw-r--r--shared/2configs/graphite.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/shared/2configs/graphite.nix b/shared/2configs/graphite.nix
new file mode 100644
index 0000000..707ec6e
--- /dev/null
+++ b/shared/2configs/graphite.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, ... }:
+
+# graphite-web on port 8080
+# carbon cache on port 2003 (tcp/udp)
+
+# TODO: krebs.graphite.minimal.enable
+# TODO: configure firewall
+with lib;
+{
+ imports = [ ];
+
+ services.graphite = {
+ web = {
+ enable = true;
+ host = "0.0.0.0";
+ };
+ carbon = {
+ enableCache = true;
+ # save disk usage by restricting to 1 bulk update per second
+ config = ''
+ [cache]
+ MAX_CACHE_SIZE = inf
+ MAX_UPDATES_PER_SECOND = 1
+ MAX_CREATES_PER_MINUTE = 50
+ '';
+ storageSchemas = ''
+ [carbon]
+ pattern = ^carbon\.
+ retentions = 60:90d
+
+ [default]
+ pattern = .*
+ retentions = 60s:30d,300s:1y
+ '';
+ };
+ };
+}