summaryrefslogtreecommitdiffstats
path: root/modules/tv/nginx.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-04-08 01:07:01 +0200
committertv <tv@krebsco.de>2015-05-19 23:16:56 +0200
commit305994b23565b3e0f73922ca219cbcb9872e4daa (patch)
tree14dd49072264f70f32d826fadc3489a7b101b62c /modules/tv/nginx.nix
parentee0c09d16f1e857a9f37118babc5c2a061fa9cf1 (diff)
I Like To Move It
Diffstat (limited to 'modules/tv/nginx.nix')
-rw-r--r--modules/tv/nginx.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/tv/nginx.nix b/modules/tv/nginx.nix
new file mode 100644
index 0000000..8b42061
--- /dev/null
+++ b/modules/tv/nginx.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, ... }:
+
+{
+ services.nginx =
+ let
+ name = config.networking.hostName;
+ qname = "${name}.retiolum";
+ in
+ {
+ enable = true;
+ httpConfig = ''
+ sendfile on;
+ server {
+ listen 80;
+ server_name ${name} ${qname} localhost;
+ root /srv/http/${name};
+ location ~ ^/~(.+?)(/.*)?$ {
+ alias /home/$1/public_html$2;
+ }
+ }
+ types {
+ text/css css;
+ text/html html;
+ image/svg+xml svg;
+ }
+ default_type text/html;
+ charset utf-8;
+ '';
+ };
+}