summaryrefslogtreecommitdiffstats
path: root/modules/tv/nginx.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-06-22 18:20:25 +0200
committertv <tv@krebsco.de>2015-06-22 18:20:25 +0200
commit245c7842072c8dec51ab6aca07437b826c38b242 (patch)
tree1056515620276960498f3c7455624802d6173620 /modules/tv/nginx.nix
parent14f619e3efbea9d614aa46f3d0d04b8d7d0c8e33 (diff)
tv: modularize nginx
Diffstat (limited to 'modules/tv/nginx.nix')
-rw-r--r--modules/tv/nginx.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/tv/nginx.nix b/modules/tv/nginx.nix
deleted file mode 100644
index 8b42061..0000000
--- a/modules/tv/nginx.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- services.nginx =
- let
- name = config.networking.hostName;
- qname = "${name}.retiolum";
- in
- {
- enable = true;
- httpConfig = ''
- sendfile on;
- server {
- listen 80;
- server_name ${name} ${qname} localhost;
- root /srv/http/${name};
- location ~ ^/~(.+?)(/.*)?$ {
- alias /home/$1/public_html$2;
- }
- }
- types {
- text/css css;
- text/html html;
- image/svg+xml svg;
- }
- default_type text/html;
- charset utf-8;
- '';
- };
-}