summaryrefslogtreecommitdiffstats
path: root/modules/mors/repos.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-06-14 19:22:37 +0200
committertv <tv@krebsco.de>2015-06-14 19:22:37 +0200
commite9970fc3bdaf204ce0999058017a471e1efcfaa9 (patch)
tree6a36b91b0ed33ba90b4da32d1fa995789f923a8d /modules/mors/repos.nix
parent55e6974bdf76ca7a7e0df6a8e99c70ab01dda74e (diff)
parent3eb5e2ace450035c0cdff424e68eed6906e997e1 (diff)
Merge remote-tracking branch 'mors/master' into mors-staging
Diffstat (limited to 'modules/mors/repos.nix')
-rw-r--r--modules/mors/repos.nix78
1 files changed, 78 insertions, 0 deletions
diff --git a/modules/mors/repos.nix b/modules/mors/repos.nix
new file mode 100644
index 0000000..e31ba94
--- /dev/null
+++ b/modules/mors/repos.nix
@@ -0,0 +1,78 @@
+{ ... }:
+
+{
+ imports = [
+ ../lass/gitolite-base.nix
+ ../common/krebs-keys.nix
+ ../common/krebs-repos.nix
+ ];
+
+ services.gitolite = {
+ repos = {
+
+ config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ pass = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ load-env = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ emse-hsdb = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ brain = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ #hooks.post-receive = irc-announce;
+ };
+
+ painload = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ services = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ xmonad-config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ };
+ };
+}