summaryrefslogtreecommitdiffstats
path: root/modules/mors/git.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-06-19 01:00:11 +0200
committertv <tv@krebsco.de>2015-06-19 01:00:11 +0200
commit6b5472e49c7bc3fadcf21ae2baad73b9fab643b5 (patch)
treec7844cc7f90282ad231a379dcc0b6b8b48562f43 /modules/mors/git.nix
parentf9084414d1c6e5cd71d795ab07a8d0345e3ad620 (diff)
parent85405633fd4b8484415a5eae2fa868570d52aa6c (diff)
Merge remote-tracking branch 'mors/master' into morse-merge
Diffstat (limited to 'modules/mors/git.nix')
-rw-r--r--modules/mors/git.nix71
1 files changed, 71 insertions, 0 deletions
diff --git a/modules/mors/git.nix b/modules/mors/git.nix
new file mode 100644
index 0000000..1dd61d1
--- /dev/null
+++ b/modules/mors/git.nix
@@ -0,0 +1,71 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports = [
+ ../tv/git
+ ];
+
+ services.git =
+ let
+ inherit (builtins) readFile;
+ # TODO lib should already include our stuff
+ inherit (import ../../lib { inherit lib pkgs; }) addNames git;
+
+ krebs-private = name: desc:
+ {
+ inherit desc;
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ }
+ in rec {
+ enable = true;
+
+ users = addNames {
+ tv = { pubkey = readFile <pubkeys/tv.ssh.pub>; };
+ lass = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
+ uriel = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
+ makefu = { pubkey = "xxx"; };
+ };
+
+ repos = addNames {
+ shitment = {
+ desc = "shitment repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
+ testing = {
+ desc = "testing repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#repository";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
+ };
+
+ rules = with git; with users; with repos; [
+ { user = lass;
+ repo = [ testing shitment ];
+ perm = push master [ non-fast-forward create delete merge ];
+ }
+ { user = [ tv uriel makefu ];
+ repo = [ testing shitment ];
+ perm = fetch;
+ }
+ ];
+ };
+}