summaryrefslogtreecommitdiffstats
path: root/modules/lass/steam.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-04-10 01:37:29 +0200
committertv <tv@krebsco.de>2015-05-19 23:17:19 +0200
commit878eb2f4d0562928adf0478c509f34655f19f716 (patch)
tree9be801304c8331bc211ad738836b3f3a03e74cea /modules/lass/steam.nix
parent4264c3a24fc11d2bad8be9053d7d972f2aec4248 (diff)
mors: import mors + config
Diffstat (limited to 'modules/lass/steam.nix')
-rw-r--r--modules/lass/steam.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/lass/steam.nix b/modules/lass/steam.nix
new file mode 100644
index 0000000..d54873b
--- /dev/null
+++ b/modules/lass/steam.nix
@@ -0,0 +1,29 @@
+{ config, pkgs, ... }:
+
+{
+
+ imports = [
+ ./games.nix
+ ];
+ #
+ # Steam stuff
+ # source: https://nixos.org/wiki/Talk:Steam
+ #
+ ##TODO: make steam module
+ hardware.opengl.driSupport32Bit = true;
+
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ networking.firewall = {
+ allowedUDPPorts = [
+ 27031
+ 27036
+ ];
+ allowedTCPPorts = [
+ 27036
+ 27037
+ ];
+ };
+
+}