summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-01-10 13:20:04 +0100
committermakefu <github@syntax-fehler.de>2023-01-10 13:20:04 +0100
commited48ea7ef4ad6874588962f351389c2af36d8199 (patch)
tree982b449bc39748236d6e563f2bd388079256acab /lib/types.nix
parentaa1e058ba6e8c3e701a2503d65ddb3c83d5c4f47 (diff)
parent206a5d145418c3484100b0598a9593a950fbfc98 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix19
1 files changed, 16 insertions, 3 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 67a0c6f..32b4541 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -18,9 +18,6 @@ rec {
type = label;
default = config._module.args.name;
};
- cores = mkOption {
- type = uint;
- };
nets = mkOption {
type = attrsOf net;
default = {};
@@ -149,6 +146,14 @@ rec {
}.${config._module.args.name} or {
default = "${ip4.config.addr}/32";
});
+ prefixLength = mkOption ({
+ type = uint;
+ } // {
+ retiolum.default = 16;
+ wiregrill.default = 16;
+ }.${config._module.args.name} or {
+ default = 32;
+ });
};
}));
default = null;
@@ -168,6 +173,14 @@ rec {
}.${config._module.args.name} or {
default = "${ip6.config.addr}/128";
});
+ prefixLength = mkOption ({
+ type = uint;
+ } // {
+ retiolum.default = 32;
+ wiregrill.default = 32;
+ }.${config._module.args.name} or {
+ default = 128;
+ });
};
}));
default = null;