summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-05-09 11:07:27 +0200
committertv <tv@krebsco.de>2018-05-09 11:07:27 +0200
commitd43c1e5bb1c5405e67a02ada342c94ed13214aa7 (patch)
tree83acc249ebbc8e5ca6b80fb1b6583a01321d8258 /lib/types.nix
parentf74a1e121dfc69dfca92c1e83c3abcc20c81b5a8 (diff)
parent6d8a79f91ff4661f06228505349c8c2ee41a9b25 (diff)
Merge remote-tracking branch 'prism/master' (despite bad style)
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 1cf2d96..d663d25 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -50,6 +50,14 @@ rec {
default = false;
};
+ monitoring = mkOption {
+ description = ''
+ Whether the host should be monitored by monitoring tools like Prometheus.
+ '';
+ type = bool;
+ default = false;
+ };
+
owner = mkOption {
type = user;
};