summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-05-04 16:57:21 +0200
committerjeschli <jeschli@gmail.com>2018-05-04 16:57:21 +0200
commit9afb5e21a67c19f538ae942fca282fd83591411f (patch)
tree4e82415935de6087727211f022a70f648717ea0c /lib/types.nix
parent100952da70df8971f935e5e1a3e2d2c11601824d (diff)
parent35be141b5e7e31b76590f3bd9647d1e7c0d1c04f (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 1cf2d96..d663d25 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -50,6 +50,14 @@ rec {
default = false;
};
+ monitoring = mkOption {
+ description = ''
+ Whether the host should be monitored by monitoring tools like Prometheus.
+ '';
+ type = bool;
+ default = false;
+ };
+
owner = mkOption {
type = user;
};