summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorMarkus Hihn <markus.hihn@dcso.de>2017-12-15 19:58:16 +0100
committerMarkus Hihn <markus.hihn@dcso.de>2017-12-15 19:58:16 +0100
commit8089288dbac0f19507c68f1b6d5223d77de22368 (patch)
tree3f44c7ce34768be3e8bce807a47b92e5b7d341cc /lib/types.nix
parentd2d67f5432b19fd5a81d9629e6731bb84f968998 (diff)
parentcbab8d33d76c1d85d70c38777ecde14abe8ed1b9 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix22
1 files changed, 21 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index c3b14d8..b857949 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -231,7 +231,12 @@ rec {
source = submodule ({ config, ... }: {
options = {
type = let
- types = ["file" "git" "symlink"];
+ types = [
+ "file"
+ "git"
+ "pass"
+ "symlink"
+ ];
in mkOption {
type = enum types;
default = let
@@ -255,6 +260,10 @@ rec {
type = nullOr git-source;
default = null;
};
+ pass = mkOption {
+ type = nullOr pass-source;
+ default = null;
+ };
symlink = let
symlink-target = (symlink-source.getSubOptions "FIXME").target.type;
in mkOption {
@@ -287,6 +296,17 @@ rec {
};
};
+ pass-source = submodule {
+ options = {
+ dir = mkOption {
+ type = absolute-pathname;
+ };
+ name = mkOption {
+ type = pathname; # TODO relative-pathname
+ };
+ };
+ };
+
symlink-source = submodule {
options = {
target = mkOption {