summaryrefslogtreecommitdiffstats
path: root/lib/haskell.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-01-10 13:20:04 +0100
committermakefu <github@syntax-fehler.de>2023-01-10 13:20:04 +0100
commited48ea7ef4ad6874588962f351389c2af36d8199 (patch)
tree982b449bc39748236d6e563f2bd388079256acab /lib/haskell.nix
parentaa1e058ba6e8c3e701a2503d65ddb3c83d5c4f47 (diff)
parent206a5d145418c3484100b0598a9593a950fbfc98 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/haskell.nix')
-rw-r--r--lib/haskell.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/haskell.nix b/lib/haskell.nix
index 4f0ee05..f87cfa7 100644
--- a/lib/haskell.nix
+++ b/lib/haskell.nix
@@ -39,7 +39,12 @@ rec {
in
if parse == null then
(pkgs.writeText name s).overrideAttrs (old: {
- dependencies = old.dependencies or [] ++ dependencies;
+ dependencies =
+ lib.uniq
+ (lib.sort (lib.on lib.lessThan (lib.getAttr "name"))
+ (filter
+ (lib.ne null)
+ (old.dependencies or [] ++ dependencies)));
})
else