summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-02-26 08:58:51 +0100
committermakefu <github@syntax-fehler.de>2019-02-26 08:58:51 +0100
commitdd82082d47a4b0ca727d7554d11dcf4a21a6dba0 (patch)
tree369a2edadf6ede1fbcb72ff221b63efa83ec44b8 /lib/default.nix
parent7b4d148ab96e136f201e548ab81ef71cb29d8483 (diff)
parent3a25fe69295e477ea103ab7010e2a43e37191c62 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 347830e..8ba55b5 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -9,6 +9,7 @@ let
krops = import ../submodules/krops/lib;
shell = import ./shell.nix { inherit lib; };
types = nixpkgs-lib.types // import ./types.nix { inherit lib; };
+ xml = import ./xml.nix { inherit lib; };
eq = x: y: x == y;
ne = x: y: x != y;
@@ -145,6 +146,11 @@ let
in
filter (x: x != []) ([acc.chunk] ++ acc.chunks);
+ warnOldVersion = oldName: newName:
+ if compareVersions oldName newName != -1 then
+ trace "Upstream `${oldName}' gets overridden by `${newName}'." newName
+ else
+ newName;
};
in