summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
committermakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
commitaa1e058ba6e8c3e701a2503d65ddb3c83d5c4f47 (patch)
treeea3e3bbc78c78f39b2a8e123901867e1e68c21c7 /lib/default.nix
parent3a65e49a98fc1721cbc34859a18d324789abfeee (diff)
parentc0378866356b182206aa7ad47f1139cf37f697f4 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 7c3b037..149b97a 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -95,9 +95,12 @@ let
path = dirPath + "/${relPath}";
in
nameValuePair (toPackageName name) (f path))
- (filter
- (name: name != "default.nix" && !hasPrefix "." name)
- (attrNames (readDir dirPath))));
+ (attrNames
+ (filterAttrs isNixDirEntry (readDir dirPath))));
+
+ isNixDirEntry = name: type:
+ (type == "regular" && hasSuffix ".nix" name && name != "default.nix") ||
+ (type == "directory" && !hasPrefix "." name);
# https://tools.ietf.org/html/rfc5952
normalize-ip6-addr =
@@ -191,3 +194,4 @@ let
in
lib
+// { inherit lib; }