summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/reagenzglas/hardware-configuration.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-14 10:17:40 +0100
committertv <tv@krebsco.de>2017-12-14 10:17:40 +0100
commit02b5a5f33f9455cd83add77b5a93c0b6765d2b58 (patch)
tree3a9dc56d7a3606ee2ab999572214a790348a496b /jeschli/1systems/reagenzglas/hardware-configuration.nix
parent6e985f09b70f5a4dbfe5d3aa1c9df0cefd672250 (diff)
parenta95d6929ca8b54a2eec2b8a0bcd2ce71f835cf15 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'jeschli/1systems/reagenzglas/hardware-configuration.nix')
-rw-r--r--jeschli/1systems/reagenzglas/hardware-configuration.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/jeschli/1systems/reagenzglas/hardware-configuration.nix b/jeschli/1systems/reagenzglas/hardware-configuration.nix
new file mode 100644
index 0000000..a6ab3f1
--- /dev/null
+++ b/jeschli/1systems/reagenzglas/hardware-configuration.nix
@@ -0,0 +1,33 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "sd_mod" "sr_mod" "rtsx_pci_sdmmc" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/09130cf7-b71b-42ab-9fa3-cb3c745f1fc9";
+ fsType = "ext4";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/8bee50b3-5733-4373-a966-388def141774";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/DA40-AC19";
+ fsType = "vfat";
+ };
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 8;
+# powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}