summaryrefslogtreecommitdiffstats
path: root/Zpkgs/krebs/hashPassword.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-24 23:57:12 +0200
committermakefu <github@syntax-fehler.de>2015-07-24 23:57:12 +0200
commit784929d0015547f2a314651ac67f095aee16c6ca (patch)
tree7dd2fe60d733d8220d74d312a8ee3b5780e01d73 /Zpkgs/krebs/hashPassword.nix
parent55b9e8b4d0fa2c3b982038cf783a2ccdbe36ff6e (diff)
parent3453edadf2ac2fb76e9e690655dd9f4981e7e9c1 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'Zpkgs/krebs/hashPassword.nix')
-rw-r--r--Zpkgs/krebs/hashPassword.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/Zpkgs/krebs/hashPassword.nix b/Zpkgs/krebs/hashPassword.nix
new file mode 100644
index 0000000..a10340c
--- /dev/null
+++ b/Zpkgs/krebs/hashPassword.nix
@@ -0,0 +1,16 @@
+{ lib, pkgs, ... }:
+
+pkgs.writeScriptBin "hashPassword" ''
+ #! /bin/sh
+ # usage: hashPassword
+ set -euf
+
+ export PATH=${lib.makeSearchPath "bin" (with pkgs; [
+ coreutils
+ mkpasswd
+ openssl
+ ])}
+
+ salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
+ exec mkpasswd -m sha-512 -S "$salt"
+''