summaryrefslogtreecommitdiffstats
path: root/4lib/tv/modules.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
commit7acd1262519d8f15c8eb89a0dce968eb26d6b7d4 (patch)
tree71f807a36e60e126b6fdb0be51e70cde4bf64b4e /4lib/tv/modules.nix
parent7673c84204bd5bae0426b79c62e95dfccf846756 (diff)
parent7920cfad18e69ea30bbe5e70da2cd93e0bbc05cd (diff)
Merge branch 'tv' into master
Diffstat (limited to '4lib/tv/modules.nix')
-rw-r--r--4lib/tv/modules.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/4lib/tv/modules.nix b/4lib/tv/modules.nix
deleted file mode 100644
index 248e638..0000000
--- a/4lib/tv/modules.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-let
- pkgs = import <nixpkgs> {};
- inherit (pkgs.lib) concatMap hasAttr;
-in rec {
-
- no-touch-args = {
- config = throw "no-touch-args: can't touch config!";
- lib = throw "no-touch-args: can't touch lib!";
- pkgs = throw "no-touch-args: can't touch pkgs!";
- };
-
- # list-imports : path -> [path]
- # Return a module's transitive list of imports.
- # XXX duplicates won't get eliminated from the result.
- list-imports = path:
- let module = import path no-touch-args;
- imports = if hasAttr "imports" module
- then concatMap list-imports module.imports
- else [];
- in [path] ++ imports;
-}