summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2024-06-04 14:06:57 +0200
committertv <tv@krebsco.de>2024-06-04 14:06:57 +0200
commit59a5db0684922f1318e9c36970290f17a6d7f7ed (patch)
treed59b918ad02d2752e586eda6bc78aa6fa144d892 /shell.nix
parent3bd075759e68b6019e9d5896b1c889b7d5fbb967 (diff)
modernize build system
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..48d4bf4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,31 @@
+{ compiler ? "default"
+, nixpkgs ? import <nixpkgs> {}
+}: let
+
+ inherit (nixpkgs) lib pkgs;
+
+ haskellPackages =
+ if compiler == "default" then
+ pkgs.haskellPackages
+ else
+ pkgs.haskell.packages.${compiler};
+
+ drv = haskellPackages.callPackage (import ./package.nix) {};
+
+in
+
+ lib.overrideDerivation drv.env (oldAttrs: {
+ buildInputs = [
+ pkgs.cabal-install
+ ];
+ shellHook = ''
+ CABAL_BUILD_DIR=$HOME/tmp/cache/${drv.pname}
+ cabal() {
+ command=$1; shift
+ ${pkgs.cabal-install}/bin/cabal \
+ "$command" \
+ --builddir="$CABAL_BUILD_DIR" \
+ "$@"
+ }
+ '';
+ })