From 966620d6c64bbb2a375e2dc30d8a70c636cd8864 Mon Sep 17 00:00:00 2001
From: makefu <github@syntax-fehler.de>
Date: Thu, 4 Apr 2019 09:11:33 +0200
Subject: ma pkgs.prison-break: init at 0.1.0

---
 makefu/5pkgs/prison-break/default.nix         | 20 ++++++++++++++++++++
 makefu/5pkgs/prison-break/straight-plugin.nix | 22 ++++++++++++++++++++++
 2 files changed, 42 insertions(+)
 create mode 100644 makefu/5pkgs/prison-break/default.nix
 create mode 100644 makefu/5pkgs/prison-break/straight-plugin.nix

(limited to 'makefu/5pkgs/prison-break')

diff --git a/makefu/5pkgs/prison-break/default.nix b/makefu/5pkgs/prison-break/default.nix
new file mode 100644
index 000000000..f86ac3762
--- /dev/null
+++ b/makefu/5pkgs/prison-break/default.nix
@@ -0,0 +1,20 @@
+{pkgs, fetchFromGitHub}:
+with pkgs.python3.pkgs;
+
+buildPythonPackage rec {
+  pname = "prison-break";
+  version = "0.1.0";
+  src = fetchFromGitHub {
+    owner = "makefu";
+    repo = pname;
+    rev = "5eed6371e151e716faafa054e005bd98d77b4b5d";
+    sha256 = "170zs9grbgkx83ghg6pm13v7vhi604y44j550ypp2x26nidaw63j";
+  };
+  propagatedBuildInputs = [
+    docopt
+    requests
+    beautifulsoup4
+    (callPackage ./straight-plugin.nix {})
+  ];
+  checkInputs = [ black ];
+}
diff --git a/makefu/5pkgs/prison-break/straight-plugin.nix b/makefu/5pkgs/prison-break/straight-plugin.nix
new file mode 100644
index 000000000..606c60b5d
--- /dev/null
+++ b/makefu/5pkgs/prison-break/straight-plugin.nix
@@ -0,0 +1,22 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+  pname = "straight-plugin";
+  version = "1.5.0";
+
+  src = fetchPypi {
+    pname = "straight.plugin";
+    inherit version;
+    sha256 = "818a7641068932ed6436d0af0a3bb77bbbde29df0a7142c8bd1a249e7c2f0d38";
+  };
+
+  meta = with lib; {
+    description = "A simple namespaced plugin facility";
+    homepage = https://github.com/ironfroggy/straight.plugin;
+    license = licenses.mit;
+    maintainers = [ maintainers.makefu ];
+  };
+}
-- 
cgit v1.2.3