From e7779d8016cc06c5b7383e25a2e0608666495ca2 Mon Sep 17 00:00:00 2001
From: makefu <github@syntax-fehler.de>
Date: Mon, 5 Oct 2015 17:51:14 +0200
Subject: makefu {1,2} Reaktor: add random-emoji plugin to Reaktor to pnp"

---
 makefu/2configs/Reaktor/random-emoji.nix | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 makefu/2configs/Reaktor/random-emoji.nix

(limited to 'makefu/2configs/Reaktor/random-emoji.nix')

diff --git a/makefu/2configs/Reaktor/random-emoji.nix b/makefu/2configs/Reaktor/random-emoji.nix
new file mode 100644
index 000000000..b2d99b36b
--- /dev/null
+++ b/makefu/2configs/Reaktor/random-emoji.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with pkgs;
+let
+  rpkg = pkgs.substituteAll( {
+    name="random-emoji";
+    dir= "bin";
+    isExecutable=true;
+    src= ./random-emoji.sh;
+    });
+  rpkg-path = lib.makeSearchPath "bin" (with pkgs; [
+                        coreutils
+                        gnused
+                        gnugrep
+                        curl]);
+in {
+  # TODO: make origin a variable, <- module is generic enough to handle different origins, not only stockholm
+  krebs.Reaktor.extraConfig = ''
+  public_commands.insert(0,{
+    'capname' : "emoji",
+    'pattern' : indirect_pattern.format("emoji"),
+    'argv'    : ["${rpkg}/bin/random-emoji"],
+    'env'     : { 'PATH':'${rpkg-path}' } })
+  '';
+}
-- 
cgit v1.2.3