summaryrefslogtreecommitdiffstats
path: root/src/coding/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/coding/Makefile.am')
-rw-r--r--src/coding/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/coding/Makefile.am b/src/coding/Makefile.am
new file mode 100644
index 00000000..5a055c8d
--- /dev/null
+++ b/src/coding/Makefile.am
@@ -0,0 +1,27 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool
+# documentation before making any modification
+LIBVERSION = 0:0:0
+
+AM_CPPFLAGS = -I$(top_srcdir)/include $(TALLOC_CFLAGS)
+AM_CFLAGS = -Wall
+
+lib_LTLIBRARIES = libosmocoding.la
+
+libosmocoding_la_SOURCES = \
+ gsm0503_interleaving.c \
+ gsm0503_mapping.c \
+ gsm0503_tables.c \
+ gsm0503_parity.c \
+ gsm0503_coding.c
+libosmocoding_la_LDFLAGS = \
+ -version-info \
+ $(LIBVERSION) \
+ -no-undefined \
+ $(TALLOC_LIBS)
+libosmocoding_la_LIBADD = \
+ ../libosmocore.la \
+ ../gsm/libosmogsm.la \
+ ../codec/libosmocodec.la
+
+EXTRA_DIST = libosmocoding.map