summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-10-26 20:14:04 +0100
committerHarald Welte <laforge@gnumonks.org>2014-10-26 20:14:04 +0100
commita97ebc9599d4b3210d7127a2cc75d552e69eeb9a (patch)
tree60eee24f5b78ad5115b21cb9996406e5cbf4fd3d /configure.ac
parent42645d7d78a22db7b76039407b7b43bc0cc79c54 (diff)
parent534163badec879a644af985c9f5d04b7c957a355 (diff)
Merge branch 'laforge/sim'
This contains some work from 2012 about creating a general library about the data structure of data contained on SIM cards. This 'libosmosim' is supposed to be used by (among others) * tools to review/modify/personalize SIM card filesystem data * virtual SIM card implementation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index deaa8bf7..80e2bccb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,16 @@ CHECK_TM_INCLUDES_TM_GMTOFF
dnl Generate the output
AC_CONFIG_HEADER(config.h)
+AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC support])],
+ [
+ osmo_ac_have_pcsc=$enableval
+ ],
+ [
+ PKG_CHECK_MODULES(PCSC, libpcsclite)
+ osmo_ac_have_pcsc="yes"
+ ])
+AM_CONDITIONAL(ENABLE_PCSC, test "x$osmo_ac_have_pcsc" = "xyes")
+
AC_ARG_ENABLE(talloc,
[AS_HELP_STRING(
[--disable-talloc],
@@ -187,10 +197,12 @@ AC_OUTPUT(
libosmogsm.pc
libosmogb.pc
libosmoctrl.pc
+ libosmosim.pc
include/Makefile
src/Makefile
src/vty/Makefile
src/codec/Makefile
+ src/sim/Makefile
src/gsm/Makefile
src/gb/Makefile
src/ctrl/Makefile